Port pipacs to -ng
[packages.git] / utils / pipacs / Makefile
diff --git a/utils/pipacs/Makefile b/utils/pipacs/Makefile
new file mode 100644 (file)
index 0000000..3501934
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pipacs
+PKG_RELEASE:=2
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pipacs
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=UNIX socket accounting/wiewer program
+  DESCRIPTION:=An UNIX socket accounting/wiewer program.\\\
+       This is version 2.
+endef
+
+define Build/Prepare   
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+           $(TARGET_CONFIGURE_OPTS) \
+           CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include" \
+           all
+endef
+
+define Package/pipacs/install  
+       mkdir -p $(1)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/pipacs $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,pipacs))