packages/tcsh: fix whitespaces
[packages.git] / utils / pciutils / Makefile
index fdf772f..93f35e0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=3.1.7
-PKG_RELEASE:=2
+PKG_VERSION:=3.2.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
-PKG_MD5SUM:=35222edb86b50a6641352c66fe829b2e
+PKG_MD5SUM:=d73a1b35e5d5efa70e8476d5917de11f
 
 PKG_INSTALL:=1
 
@@ -28,12 +28,13 @@ define Package/pciutils
 endef
 
 define Package/pciutils/description
-       This package contains various utilities for inspecting and setting of
-       devices connected to the PCI bus.
+ contains collection of programs for inspecting and manipulating configuration
+ of PCI devices
 endef
 
 define Package/pciutils/postinst
 #!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] || \
 (cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids; rm pci.ids.gz.old)
 exit 0
 endef
@@ -44,6 +45,10 @@ MAKE_FLAGS += \
        HOST="$(GNU_TARGET_NAME)" \
        ZLIB="yes" \
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+TARGET_LDFLAGS += -lresolv
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib