[packages] asterisk-chan-sccp-b: asterisk18-chan-sccp-b depends on libltdl
[packages.git] / utils / pciutils / Makefile
index cac5fb6..32c0f69 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
 PKG_VERSION:=3.1.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -34,7 +34,8 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
-(cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids)
+[ -z "$${IPKG_INSTROOT}" ] || \
+(cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids; rm pci.ids.gz.old)
 exit 0
 endef
 
@@ -44,6 +45,10 @@ MAKE_FLAGS += \
        HOST="$(GNU_TARGET_NAME)" \
        ZLIB="yes" \
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+TARGET_LDFLAGS += -lresolv
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib