packages/mc: remove trailing whitespace
[packages.git] / utils / mc / Makefile
index 81cf9fe..b3ba291 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2011 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
-PKG_VERSION:=4.7.5.2
+PKG_VERSION:=4.8.10
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
-PKG_MD5SUM:=9fdfe7c0fcff362436eb35fcd1adf0fd
+PKG_MD5SUM:=eb4bdc23abd4fdfa14911d53d65c8186
 
 PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -23,11 +24,15 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/mc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+glib2 +libncurses +libiconv
+  DEPENDS:=+glib2 +libncurses $(LIBRPC_DEPENDS) $(ICONV_DEPENDS)
   TITLE:=midnight commander - a powerful file manager
   URL:=http://www.midnight-commander.org/
   SUBMENU:=filemanager
-  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
+  MENU:=1
+endef
+
+define Package/mc/config
+       source "$(SOURCE)/Config.in"
 endef
 
 define Package/mc/description
@@ -40,30 +45,47 @@ endef
 
 CONFIGURE_ARGS += \
        --enable-utf8 \
-       --disable-vfs \
+       --disable-doxygen-doc \
+       --disable-vfs-sftp \
        --with-screen=ncurses \
-       --without-edit \
        --without-gpm-mouse \
-       --without-subshell \
-       --without-x
+       --without-x \
+       ac_cv_search_addwstr=no
 
-AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
+ifeq ($(CONFIG_MC_DIFF_VIEWER),n)
+CONFIGURE_ARGS += \
+       --without-diff-viewer
+endif
 
-define Build/Prepare
-       $(Build/Prepare/Default)
-       for script in config.guess config.sub depcomp install-sh missing; do \
-               rm -f $(PKG_BUILD_DIR)/config/$$$$script; \
-               ln -s $(AM_HOST)/$$$$script $(PKG_BUILD_DIR)/config/$$$$script; \
-       done
-endef
+ifeq ($(CONFIG_MC_EDITOR),n)
+CONFIGURE_ARGS += \
+       --without-edit
+endif
+
+ifeq ($(CONFIG_MC_SUBSHELL),n)
+CONFIGURE_ARGS += \
+       --without-subshell
+endif
+
+ifeq ($(CONFIG_MC_DISABLE_VFS),y)
+CONFIGURE_ARGS += \
+       --without-vfs
+endif
 
 define Package/mc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
        $(INSTALL_DIR) $(1)/etc/mc
+ifeq ($(CONFIG_MC_DIFF_VIEWER),y)
+       ln -sf mc $(1)/usr/bin/mcdiff
+endif
+ifeq ($(CONFIG_MC_EDITOR),y)
+       ln -sf mc $(1)/usr/bin/mcedit
+endif
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.menu $(1)/etc/mc
        $(INSTALL_DIR) $(1)/etc/mc/skins
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/skins/default.ini $(1)/etc/mc/skins
+       $(INSTALL_DIR) $(1)/root/.mc/cedit/Syntax
 endef
 
 define Package/mc/conffiles