[package] upgrade mc to 4.7.5.1
[packages.git] / utils / mc / Makefile
index 4ebd109..614f11b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,23 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
-PKG_VERSION:=4.6.1
-PKG_RELEASE:=2
+PKG_VERSION:=4.7.5.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
-PKG_MD5SUM:=18b20db6e40480a53bac2870c56fc3c4
-
-PKG_BUILD_DEPENDS:=glib1 libncurses
+PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
+PKG_MD5SUM:=e673b7ec0191e4061b5d8b69368aa113
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/mc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+glib1 +libncurses
+  DEPENDS:=+glib2 +libncurses +libiconv
   TITLE:=midnight commander - a powerful file manager
-  URL:=http://www.ibiblio.org/mc/
+  URL:=http://www.midnight-commander.org/
   SUBMENU:=filemanager
 endef
 
@@ -39,40 +38,26 @@ define Package/mc/description
 endef
 
 CONFIGURE_ARGS += \
-       --prefix=/usr \
-       --disable-nls \
-       --with-included-gettext \
-       --with-ncurses \
-       --without-sco \
-       --without-sunos-curses \
-       --without-osf1-curses \
-       --without-vcurses \
+       --without-edit \
        --without-gpm-mouse \
-       --without-hsc \
-       --without-termnet \
-       --without-debug \
-       --without-efence \
-       --without-terminfo \
-       --without-termcap \
-       --without-slang \
-       --without-vfs \
-       --without-netrc \
-       --without-ext2undel \
-       --without-catgets \
-       --without-x \
-       --without-tk \
-       --without-xview \
        --without-subshell \
-       --disable-glibtest \
-       --with-glib12 \
-       --with-glib-prefix="$(STAGING_DIR)/usr" \
-       , \
-       PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
+       --without-x \
+       --disable-vfs \
+       --with-screen=ncurses
+
+AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
+
+define Build/Prepare
+       $(Build/Prepare/Default)
+       for script in config.guess config.sub depcomp install-sh missing; do \
+               rm -f $(PKG_BUILD_DIR)/config/$$$$script; \
+               ln -s $(AM_HOST)/$$$$script $(PKG_BUILD_DIR)/config/$$$$script; \
+       done
+endef
 
 define Package/mc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
-       ln -sf mc $(1)/usr/bin/mcedit
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,mc))