packages/tinc: fix pid-file arg passed in service command-line
[packages.git] / utils / macchanger / Makefile
index 467bdee..acd3bc9 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/macchanger
 PKG_MD5SUM:=79b7cdaeca3d8ebafa764c4b0dd03ab7
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,21 +23,17 @@ define Package/macchanger
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=utility for viewing/manipulating the MAC address
-  DESCRIPTION:=\
-       This is a GNU/Linux utility for viewing/manipulating the MAC address \\\
-       of network interfaces.
   URL:=http://www.alobbs.com/macchanger
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/macchanger/description
+       This is a GNU/Linux utility for viewing/manipulating the MAC address 
+       of network interfaces.
 endef
 
-define Package/macchanger/install      
+define Package/macchanger/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/macchanger $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/macchanger $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/macchanger $(1)/usr/share/
 endef