update openssh to 5.5p1 and
[packages.git] / utils / lrzsz / Makefile
index 28f8a49..6e93bad 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.ohse.de/uwe/releases/
 PKG_MD5SUM:=b5ce6a74abc9b9eb2af94dffdfd372a4
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,26 +23,22 @@ define Package/lrzsz
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=X,Y and Z-modem protocols
-  DESCRIPTION:=\
-       Transfer files in your login sessions.\\\
-       Very leightweight and straight forward.\\\
-       You just need a terminal client that can do \\\
-       either X, Y or Z-modem file transfers.
   URL:=http://www.ohse.de/uwe/software/lrzsz.html
 endef
 
-# uses GNU configure
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/lrzsz/description
+       Transfer files in your login sessions.
+       Very leightweight and straight forward.
+       You just need a terminal client that can do 
+       either X, Y or Z-modem file transfers.
 endef
 
-define Package/lrzsz/install   
+# uses GNU configure
+
+define Package/lrzsz/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/lrz $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/lsz $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lrz $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lsz $(1)/usr/bin/
        (cd $(1)/usr/bin; \
                ln -fs lrz lrx; \
                ln -fs lrz lrb; \