avrdude: fix build of new version
[packages.git] / utils / joe / Makefile
index 708bdb5..875a7fd 100644 (file)
@@ -4,17 +4,23 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+
+# changes by David Kuehling <dvdkhlng TA gmx TOD de>:
+#
+#  - include support for all emulation modes jmacs jpico etc.
+#  - see patches/002-builtinrc.patch
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=joe
-PKG_VERSION:=3.5
-PKG_RELEASE:=1
+PKG_VERSION:=3.7
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/joe-editor
-PKG_MD5SUM:=9bdffecce7ef910feaa06452d48843de
+PKG_MD5SUM:=66de1b073e869ba12abbfcde3885c577
+
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,16 +30,20 @@ define Package/joe
   DEPENDS:=+libncurses
   TITLE:=JOE - Joes own editor
   URL:=http://sourceforge.net/projects/joe-editor/
-  SUBMENU:=editors
+  SUBMENU:=Editors
 endef
 
 define Package/joe/description
-Joe is world-famous Wordstar like text editor.
+Joe is world-famous Wordstar like text editor, that also features 
+Emacs and Pico emulation
 endef
 
 define Package/joe/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/joe $(1)/usr/bin/
+       for i in jmacs jstar rjoe jpico; do \
+         ln -sf joe $(1)/usr/bin/$$$$i; \
+       done
 endef
 
 $(eval $(call BuildPackage,joe))