[packages] Add missing libtool fixups
[packages.git] / utils / hplip / Makefile
index 8ea9e73..46ce2db 100644 (file)
@@ -1,23 +1,22 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
-PKG_VERSION:=2.7.12
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.9
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
-PKG_MD5SUM:=ba00337ccf1b520509518bffbec960db
+PKG_MD5SUM:=2e20dba86abb99a3ca59d05e814ce9a1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS := python
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,7 +38,16 @@ CONFIGURE_ARGS += \
        --disable-fax-build \
        --disable-pp-build \
        --disable-doc-build \
-       --disable-foomatic-xml-install
+       --disable-foomatic-xml-install \
+       --disable-dbus-build
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               $(CONFIGURE_ARGS),\
+               ac_cv_lib_cups_cupsDoFileRequest=yes \
+               LIBS="-ljpeg -lusb" \
+       )
+endef
 
 define Package/hplip/install
        $(INSTALL_DIR) $(1)/usr/lib