packages/smartmontools: use new service functions
[packages.git] / utils / dbus / Makefile
index 35a6aa6..91e2024 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 
 # Make sure to also update the dbus-x package
 PKG_NAME:=dbus
-PKG_VERSION:=1.2.12
+PKG_VERSION:=1.4.14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
-PKG_MD5SUM:=39bd582c3b06a261cac44d4cab6fd60b
+PKG_MD5SUM:=ae6de2562a57516cfabaf56903375ba9
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -54,7 +54,7 @@ endef
 define Package/dbus
 $(call Package/dbus/Default)
  TITLE+= (daemon)
- DEPENDS:= +libexpat +libdbus
+ DEPENDS:= +libexpat +libdbus +librt
 endef
 
 define Package/dbus/Description
@@ -74,6 +74,11 @@ $(call Package/dbus/Default/description)
 endef
 
 
+define Build/Prepare
+       $(Build/Prepare/Default)
+       $(SED) 's/-Wl,--gc-sections/--gc-sections/' $(PKG_BUILD_DIR)/configure
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -82,7 +87,7 @@ CONFIGURE_ARGS += \
        --disable-asserts \
        --disable-console-owner-file \
        --disable-doxygen-docs \
-       --disable-gcov \
+       --disable-compiler_coverage \
        --disable-selinux \
        --disable-tests \
        --disable-verbose-mode \
@@ -97,7 +102,7 @@ CONFIGURE_ARGS += \
 
 CONFIGURE_VARS+= \
        ac_cv_have_abstract_sockets="yes" \
-       $(if $(CONFIG_LINUX_2_4),ac_cv_header_sys_inotify_h=no) \
+       ac_cv_lib_expat_XML_ParserCreate_MM="yes" \
 
 
 define Build/InstallDev