[PATCH] package/yaddns: bump version, add uci compatibility
[packages.git] / utils / cifsmount / Makefile
index 147e09b..a8cb2da 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,16 +18,15 @@ include $(INCLUDE_DIR)/package.mk
 define Package/cifsmount
   SECTION:=utils
   CATEGORY:=Utilities
+  SUBMENU:=Filesystem
   TITLE:=CIFS mounting helper utility
-  DESCRIPTION:=Helper utility for mounting remote CIFS shares.\\\
-    An user space helper for mounting remote CIFS shares
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
+define Package/cifsmount/description
+       An user space helper utility for mounting remote CIFS shares.
 endef
 
-define Build/Configure
+define Build/Prepare
 endef
 
 define Build/Compile
@@ -36,8 +34,8 @@ define Build/Compile
 endef
 
 define Package/cifsmount/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,cifsmount))