[packages] upx: define UCL_NO_ASM to fix build on x86 (ucl is built with --disable...
[packages.git] / utils / bc / Makefile
index 9cd1edf..29b71aa 100644 (file)
@@ -4,34 +4,32 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bc
-PKG_VERSION:=1.06
+PKG_VERSION:=1.06.94
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/
-PKG_MD5SUM:=d44b5dddebd8a7a7309aea6c36fda117
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=ftp://ftp.debian.org/debian/pool/main/b/bc
+PKG_MD5SUM:=ea7704fc02b359ce92fa4360c802fb23
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bc/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  URL:=http://www.gnu.org/software/bc/
+  URL:=http://packages.debian.org/bc
 endef
 
 define Package/bc
   $(call Package/bc/Default)
   TITLE:=Arbitrary precision calculator language
-  DESCRIPTION:=\
-       bc is a language that supports arbitrary precision numbers with interactive \\\
+endef
+
+define Package/bc/description
+       bc is a language that supports arbitrary precision numbers with interactive 
        execution of statements.
 endef
 
@@ -39,19 +37,21 @@ define Package/dc
   $(call Package/bc/Default)
   DEPENDS:=bc
   TITLE:=Arbitrary precision reverse-polish calculator
-  DESCRIPTION:=\
-       dc is a reverse-polish desk calculator which supports unlimited precision \\\
+endef
+
+define Package/dc/description
+       dc is a reverse-polish desk calculator which supports unlimited precision 
        arithmetic.
 endef
 
 define Package/bc/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/bc/bc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bc/bc $(1)/usr/bin/
 endef
 
 define Package/dc/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/dc/dc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dc/dc $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,bc))