tools: add scons (patch by Dave Taht)
[15.05/openwrt.git] / tools / scons / Makefile
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
new file mode 100644 (file)
index 0000000..aadeb28
--- /dev/null
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scons
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/scons
+PKG_MD5SUM:=47daf989e303a045b76c11236df719df
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+       python $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+endef
+
+$(eval $(call HostBuild))