[backfire] targets: rename "files-2.6.x" directories to "files"
[10.03/openwrt.git] / target / linux / xburst / files / sound / soc / jz4740 / Makefile
diff --git a/target/linux/xburst/files/sound/soc/jz4740/Makefile b/target/linux/xburst/files/sound/soc/jz4740/Makefile
new file mode 100644 (file)
index 0000000..e7952d3
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Jz4740 Platform Support
+#
+snd-soc-jz4740-objs := jz4740-pcm.o
+snd-soc-jz4740-i2s-objs := jz4740-i2s.o
+
+obj-$(CONFIG_SND_JZ4740_SOC) += snd-soc-jz4740.o
+obj-$(CONFIG_SND_JZ4740_SOC_I2S) += snd-soc-jz4740-i2s.o
+
+# Jz4740 Machine Support
+snd-soc-qi-lb60-objs := qi_lb60.o
+snd-soc-n516-objs := n516.o
+snd-soc-n526-objs := n526.o
+
+obj-$(CONFIG_SND_JZ4740_SOC_QI_LB60) += snd-soc-qi-lb60.o
+obj-$(CONFIG_SND_JZ4740_SOC_N516) += snd-soc-n516.o
+obj-$(CONFIG_SND_JZ4740_SOC_N526) += snd-soc-n526.o