fix BR2_ and CONFIG_ issues
[10.03/openwrt.git] / target / linux / package / madwifi / Makefile
index 03b40d4..d42372b 100644 (file)
@@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
 include ../../rules.mk
 
 PKG_NAME:=madwifi-ng
-PKG_VERSION:=r1456-20060225
+PKG_VERSION:=r1486-20060329
 PKG_RELEASE:=1
-PKG_MD5SUM:=27ccc5ba2e463fd8bee6da74d717731d
+PKG_MD5SUM:=71f1c654531ca8516bf7cdb5e80eb10f
 
 PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -26,12 +26,12 @@ endif
 
 BUS := PCI
 
-ifneq ($(BR2_LINUX_2_4_AR531X),)
+ifneq ($(CONFIG_LINUX_2_4_AR531X),)
        BUS := AHB
 endif
-# ifneq ($(BR2_LINUX_2_6_ARUBA),)
-#      BUS := PCI AHB  # no suitable HAL for AHB yet.
-endif
+ifneq ($(CONFIG_LINUX_2_6_ARUBA),)
+       BUS := PCI AHB  # no suitable HAL for AHB yet.
+endif
 
 BUS_MODULES:=
 ifeq ($(findstring AHB,$(BUS)),AHB)