[kernel] fix build failure on vmlinux.lds with 2.6.31 (#6052)
[10.03/openwrt.git] / target / linux / generic-2.6 / patches-2.6.27 / 200-sched_esfq.patch
index 9402a57..ef4c21f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/pkt_sched.h
 +++ b/include/linux/pkt_sched.h
-@@ -173,8 +173,37 @@
+@@ -173,8 +173,37 @@ struct tc_sfq_xstats
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -40,7 +40,7 @@
  enum
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
-@@ -128,6 +128,37 @@
+@@ -128,6 +128,37 @@ config NET_SCH_SFQ
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
  
@@ -80,7 +80,7 @@
        ---help---
 --- a/net/sched/Makefile
 +++ b/net/sched/Makefile
-@@ -23,6 +23,7 @@
+@@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED)   += sch_gred.o
  obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o 
  obj-$(CONFIG_NET_SCH_DSMARK)  += sch_dsmark.o
  obj-$(CONFIG_NET_SCH_SFQ)     += sch_sfq.o
 +      struct esfq_sched_data *q = qdisc_priv(sch);
 +      int err;
 +
-+      q->quantum = psched_mtu(sch->dev); /* default */
++      q->quantum = psched_mtu(qdisc_dev(sch)); /* default */
 +      if ((err = esfq_q_init(q, opt)))
 +              return err;
 +
 +
 +      /* set up new queue */
 +      memset(&new, 0, sizeof(struct esfq_sched_data));
-+      new.quantum = psched_mtu(sch->dev); /* default */
++      new.quantum = psched_mtu(qdisc_dev(sch)); /* default */
 +      if ((err = esfq_q_init(&new, opt)))
 +              return err;
 +