[brcm63xx] add bcm63xx_spi based on reading shared/opensource/flash/spiflash.c from...
[10.03/openwrt.git] / target / linux / brcm63xx / patches-2.6.27 / 050-spi.patch
diff --git a/target/linux/brcm63xx/patches-2.6.27/050-spi.patch b/target/linux/brcm63xx/patches-2.6.27/050-spi.patch
new file mode 100644 (file)
index 0000000..7dea317
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/spi/Kconfig      2009-03-06 02:24:35.000000000 +0100
++++ b/drivers/spi/Kconfig      2009-03-06 02:25:01.000000000 +0100
+@@ -217,6 +217,13 @@
+         See the "OPB Serial Peripheral Interface (SPI) (v1.00e)"
+         Product Specification document (DS464) for hardware details.
++config SPI_BCM63XX
++      tristate "Broadcom BCM63xx SPI controller"
++      depends on BCM63XX
++      select SPI_BITBANG
++      help
++        SPI driver for the Broadcom BCM63xx SPI controller.
++
+ #
+ # Add new SPI master controllers in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile     2009-03-06 02:25:07.000000000 +0100
++++ b/drivers/spi/Makefile     2009-03-06 02:24:13.000000000 +0100
+@@ -30,6 +30,7 @@
+ obj-$(CONFIG_SPI_TXX9)                        += spi_txx9.o
+ obj-$(CONFIG_SPI_XILINX)              += xilinx_spi.o
+ obj-$(CONFIG_SPI_SH_SCI)              += spi_sh_sci.o
++obj-$(CONFIG_SPI_BCM63XX)             += bcm63xx_spi.o
+ #     ... add above this line ...
+ # SPI protocol drivers (device/link on bus)