ar71xx: sync profile/target default changes with trunk
[10.03/openwrt.git] / target / linux / ar71xx / profiles / tp-link.mk
index 1b9cace..aab7fbc 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR741NDV1/Description
@@ -16,9 +16,21 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+
+define Profile/TLWR740NV1
+    NAME:=TP-LINK TL-WR740N v1
+    PACKAGES:=
+endef
+
+define Profile/TLWR740NV1/Description
+    Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NV15/Description
@@ -29,7 +41,7 @@ $(eval $(call Profile,TLWR841NV15))
 
 define Profile/TLWR841NDV3
        NAME:=TP-LINK TL-WR841ND v3
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV3/Description
@@ -40,7 +52,7 @@ $(eval $(call Profile,TLWR841NDV3))
 
 define Profile/TLWR841NDV5
        NAME:=TP-LINK TL-WR841ND v5
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV5/Description
@@ -51,7 +63,7 @@ $(eval $(call Profile,TLWR841NDV5))
 
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV2/Description
@@ -60,9 +72,31 @@ endef
 
 $(eval $(call Profile,TLWR941NDV2))
 
+define Profile/TLWR941NDV3
+       NAME:=TP-LINK TL-WR941ND v3
+       PACKAGES:=
+endef
+
+define Profile/TLWR941NDV3/Description
+       Package set optimized for the TP-LINK TL-WR941ND v3.
+endef
+
+$(eval $(call Profile,TLWR941NDV3))
+
+define Profile/TLWR941NDV4
+       NAME:=TP-LINK TL-WR941ND v4
+       PACKAGES:=
+endef
+
+define Profile/TLWR941NDV4/Description
+       Package set optimized for the TP-LINK TL-WR941ND v4.
+endef
+
+$(eval $(call Profile,TLWR941NDV4))
+
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k hostapd-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/TLWR1043NDV1/Description