added argtables, signed off by michu-at-neophobdotcom
[packages.git] / sound / scmpc / Makefile
diff --git a/sound/scmpc/Makefile b/sound/scmpc/Makefile
new file mode 100644 (file)
index 0000000..26dd241
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 9349 2007-10-18 18:46:37Z blogic $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scmpc
+PKG_VERSION:=0.2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.berlios.de/scmpc
+PKG_MD5SUM:=f42482e4dbf398df92a36d5610b403e5
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/scmpc
+  SECTION:=sound
+  CATEGORY:=Sound
+  TITLE:=A MPD client which submits your tracks to Last.Fm
+  DEPENDS:=+curl +libdaemon +argtable +confuse
+  URL:=http://scmpc.berlios.de/
+endef
+
+define Package/scmpc/description
+  scmpc is a multithreaded, robust client for MPD to submit tracks to Audioscrobbler (Last.fm).
+endef
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+MAKE_FLAGS += \
+       $(TARGET_CONFIGURE_OPTS) \
+       $(1) \
+
+define Package/scmpc/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/scmpc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/scmpc.init $(1)/etc/init.d/scmpc
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_BUILD_DIR)/examples/scmpc.conf $(1)/etc
+endef
+
+$(eval $(call BuildPackage,scmpc))