packages/pulseaudio: run as a pulse/pulse user/group, enable deprecated oss output...
[packages.git] / sound / pulseaudio / Makefile
index 67a465d..266c5ba 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
-PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
-PKG_MD5SUM:=e5749151dbbaa7e928793f020bf1208b
+PKG_MD5SUM:=1b76932ca7c4b2aa992941e41ed4594b
 
 PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=intltool/host
@@ -94,9 +94,9 @@ define Package/pulseaudio-profiles
 endef
 
 CONFIGURE_ARGS += \
-       --with-system-user=root \
-       --with-system-group=root \
-       --with-access-group=root \
+       --with-system-user=pulse \
+       --with-system-group=pulse \
+       --with-access-group=audio \
        --with-database=simple \
        --enable-alsa \
        --disable-hal \
@@ -104,7 +104,7 @@ CONFIGURE_ARGS += \
        --disable-tcpwrap \
        --disable-nls \
        --disable-manpages \
-       --disable-oss-output \
+       --enable-oss-output \
        --disable-oss-wrapper \
        --disable-samplerate \
        --disable-per-user-esound-socket \
@@ -124,7 +124,7 @@ endif
 ifeq ($(BUILD_VARIANT),noavahi)
 CONFIGURE_ARGS += \
        --disable-avahi \
-       --disable-dbus  
+       --disable-dbus
 endif
 
 CONFIGURE_VARS += \