backfire: rt8366*: use __devinit instead of __init for the probe function to fix...
[10.03/openwrt.git] / rules.mk
index 0cb72ac..86c8f8c 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -30,6 +30,7 @@ strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
+ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
 TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))
@@ -44,6 +45,8 @@ else
   FPIC:=-fpic
 endif
 
+HOST_FPIC:=-fPIC
+
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2