[backfire] backport r28364
[10.03/openwrt.git] / package / ppp / Makefile
index d7dcc65..5b034ab 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=7
+PKG_RELEASE:=16.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -39,6 +39,16 @@ define Package/ppp/description
 This package contains the PPP (Point-to-Point Protocol) daemon.
 endef
 
+define Package/ppp/conffiles
+/etc/ppp/chap-secrets
+/etc/ppp/filter
+/etc/ppp/ip-down
+/etc/ppp/ip-up
+/etc/ppp/ipv6-down
+/etc/ppp/ipv6-up
+/etc/ppp/options
+endef
+
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
@@ -70,6 +80,11 @@ This package contains a RADIUS (Remote Authentication Dial-In User Service)
 plugin for ppp.
 endef
 
+define Package/ppp-mod-radius/conffiles
+/etc/ppp/radius.conf
+/etc/ppp/radius/
+endef
+
 define Package/chat
 $(call Package/ppp/Default)
   DEPENDS:=ppp
@@ -142,7 +157,7 @@ define Package/ppp/install
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
 endef
-       
+
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \