add maintainer ref to asteris14 and asteris14-addons upon request
[packages.git] / net / xl2tpd / Makefile
index 007dc02..d071f38 100644 (file)
@@ -1,60 +1,62 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xl2tpd
-PKG_VERSION:=1.1.09
-PKG_RELEASE:=1.0
+PKG_VERSION:=1.2.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.xelerance.com/software/xl2tpd
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=ftp://ftp.xelerance.com/xl2tpd/
+PKG_MD5SUM:=40404ea230edd9ebdd0d53f07c832520
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xl2tpd
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=
   TITLE:=An L2TP (Layer 2 Tunneling Protocol) daemon
-  DESCRIPTION:=\
-       l2tpd is the open source implementation of the L2TP tunneling \\\
-       protocol (RFC2661). It does implement both LAC and LNS role \\\
-       in a L2TP networking architecture. The main goal of this protocol is \\\
-       to tunnel PPP frame trough an ip network.
-  URL:=http://www.xelerance.com/software/xl2tpd
+  URL:=http://www.xelerance.com/software/xl2tpd/
+  SUBMENU:=VPN
 endef
 
-define Package/xl2tpd/conffiles
-/etc/xl2tpd/xl2tpd.conf
+define Package/xl2tpd/description
+l2tpd is the open source implementation of the L2TP tunneling protocol (RFC2661).
+It does implement both LAC and LNS role in a L2TP networking architecture. The
+main goal of this protocol is to tunnel PPP frame trough an IP network.
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION" \
-       )
+# XXX: CFLAGS are already set by Build/Compile/Default
+MAKE_FLAGS+= \
+       OFLAGS=""
+
+define Package/xl2tpd/conffiles
+/etc/xl2tpd/xl2tpd.conf
+/etc/xl2tpd/xl2tp-secrets
+/etc/ppp/options.xl2tpd
 endef
 
-define Package/xl2tpd/install  
+define Package/xl2tpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/xl2tpd
-       $(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
-       $(INSTALL_DATA) ./files/l2tp-secrets $(1)/etc/xl2tpd/
-       $(INSTALL_DATA) ./files/options.l2tp $(1)/etc/xl2tpd/
-#      $(INSTALL_DIR) $(1)/etc/ppp
-#      $(INSTALL_DATA) ./files/options.l2tpd $(1)/etc/ppp/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/local/sbin/xl2tpd $(1)/usr/sbin/
+
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/xl2tpd.init $(1)/etc/init.d/xl2tpd
+
+       $(INSTALL_DIR) $(1)/etc/xl2tpd
+       $(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
+       $(INSTALL_CONF) ./files/xl2tp-secrets $(1)/etc/xl2tpd/
+
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.xl2tpd $(1)/etc/ppp/
 endef
 
 $(eval $(call BuildPackage,xl2tpd))
-