cups: configure: disable acl
[packages.git] / net / wccpd / Makefile
index 0dd8e0e..b1e73da 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,38 +14,29 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/wccpd
 PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wccpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE:=a Web Cache Coordination daemon
-  DESCRIPTION:=\
-       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon \\\
-       It allows a router (running Linux) to redirect web traffic to a \\\
-       group of Squid servers using WCCP as the monitoring/controling \\\
-       protocol.
   URL:=http://wccpd.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install 
+define Package/wccpd/description
+       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon
+       It allows a router (running Linux) to redirect web traffic to a
+       group of Squid servers using WCCP as the monitoring/controling
+       protocol.
 endef
 
 define Package/wccpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wccpd))