git-svn-id: svn://svn.openwrt.org/openwrt/packages@40397 3c298f89-4303-0410-b956...
[packages.git] / net / wccpd / Makefile
index c1c8f45..b1e73da 100644 (file)
@@ -4,51 +4,39 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wccpd
 PKG_VERSION:=0.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
 
-PKG_SOURCE_URL:=@SF/wccpd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/wccpd
+PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wccpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE:=a Web Cache Coordination daemon
-  DESCRIPTION:=wccpd is a WCCP (Web Cache Coordination Protocol) server daemon\\\
-  It allows a router (running Linux) to redirect web traffic to a\\\
-  group of Squid servers using WCCP as the monitoring/controling\\\
-  protocol.\\\
   URL:=http://wccpd.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --with-gnu-ld \
-       )
-endef
-
-define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
+define Package/wccpd/description
+       wccpd is a WCCP (Web Cache Coordination Protocol) server daemon
+       It allows a router (running Linux) to redirect web traffic to a
+       group of Squid servers using WCCP as the monitoring/controling
+       protocol.
 endef
 
 define Package/wccpd/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wccpd))