nettle: Nettle can be configured to not use gmp
[packages.git] / net / vrrpd / Makefile
index 7a729c4..472578a 100644 (file)
@@ -1,45 +1,39 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vrrpd
 PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/vrrpd
 PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vrrpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Virtual Router Redundancy Protocol daemon
   URL:=http://www.sourceforge.net/projects/vrrpd
 endef
 
 define Package/vrrpd/description
-       VRRPd is an implementation of Virtual Router Redundancy 
-       Protocol as specified in rfc2338. VRRPd is interoperable with 
-       other RFC-based VRRP implementations, including Cisco and 
-       Juniper, and is included as a standard feature on ImageStream 
+       VRRPd is an implementation of Virtual Router Redundancy
+       Protocol as specified in rfc2338. VRRPd is interoperable with
+       other RFC-based VRRP implementations, including Cisco and
+       Juniper, and is included as a standard feature on ImageStream
        routers.
 endef
 
-define Package/vrrpd/conffiles
-/etc/default/vrrpd
-endef
-
-define Build/Compile   
+define Build/Compile
        $(call Build/Compile/Default, \
                DBG_OPT="" \
                MAIN_OPT="$(TARGET_CFLAGS)" \
@@ -47,13 +41,17 @@ define Build/Compile
        )
 endef
 
-define Package/vrrpd/install   
+define Package/vrrpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/vrrpd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(INSTALL_DATA) ./files/vrrpd.default $(1)/etc/default/vrrpd
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/vrrpd.config $(1)/etc/config/vrrpd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/vrrpd.init $(1)/etc/init.d/vrrpd
 endef
 
+define Package/vrrpd/conffiles
+/etc/config/vrrpd
+endef
+
 $(eval $(call BuildPackage,vrrpd))