[packages] cups: change user:group from root:root to nobody:nogroup (closes: #7180...
[packages.git] / net / vgp / Makefile
index 9435994..46f3c85 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://vgpd.freaknet.org/files/
 PKG_MD5SUM:=b8c25b5dfcb944f78bbc584be9c230c7
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,26 +23,22 @@ define Package/vgp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A daemon working like Cisco(c) HSRP
-  DESCRIPTION:=\
-       VGP (Virtual Gateway Protocol)is a very simple protocol able to \\\
-       work in a way similar to Cisco(c) HSRP. It implements the idea \\\
-       of Virtual Gateway to provide fault tollerance (and load \\\
-       balancing) on your net. Each client on your net has as its \\\
-       default gateway set to the virtual gateway and not the real router.
   URL:=http://vgpd.freaknet.org/
 endef
 
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/vgp/description
+       VGP (Virtual Gateway Protocol)is a very simple protocol able to 
+       work in a way similar to Cisco(c) HSRP. It implements the idea 
+       of Virtual Gateway to provide fault tollerance (and load 
+       balancing) on your net. Each client on your net has as its 
+       default gateway set to the virtual gateway and not the real router.
 endef
 
+# uses GNU configure
+
 define Package/vgp/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/vgpd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vgpd $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,vgp))