Upgrade unfs3 to 0.9.20 (#3662)
[packages.git] / net / unfs3 / patches / 100-no_lfl.patch
index 797dbac..db4f863 100644 (file)
@@ -1,34 +1,6 @@
-Index: unfs3-0.9.17/Makefile.in
-===================================================================
---- unfs3-0.9.17.orig/Makefile.in      2007-07-28 22:40:02.000000000 +0200
-+++ unfs3-0.9.17/Makefile.in   2007-07-28 22:40:02.000000000 +0200
-@@ -11,7 +11,7 @@
-        md5.o mount.o nfs.o password.o readdir.o user.o xdr.o winsupport.o
- CONFOBJ = Config/lib.a
- EXTRAOBJ = @EXTRAOBJ@
--LDFLAGS = @LDFLAGS@ @LIBS@ @LEXLIB@
-+LDFLAGS = @LDFLAGS@ @LIBS@
- EXEEXT = @EXEEXT@
- prefix = @prefix@
-Index: unfs3-0.9.17/configure
-===================================================================
---- unfs3-0.9.17.orig/configure        2007-07-28 22:40:02.000000000 +0200
-+++ unfs3-0.9.17/configure     2007-07-28 22:40:02.000000000 +0200
-@@ -2122,7 +2122,7 @@
-   echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-   ac_check_lib_save_LIBS=$LIBS
--LIBS="-lfl  $LIBS"
-+LIBS="$LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h.  */
- _ACEOF
-Index: unfs3-0.9.17/Config/lex.yy.c
-===================================================================
---- unfs3-0.9.17.orig/Config/lex.yy.c  2007-07-28 22:40:21.000000000 +0200
-+++ unfs3-0.9.17/Config/lex.yy.c       2007-07-28 22:40:56.000000000 +0200
-@@ -442,9 +442,15 @@
+--- a/Config/lex.yy.c
++++ b/Config/lex.yy.c
+@@ -445,9 +445,15 @@
  
  #ifndef YY_SKIP_YYWRAP
  #ifdef __cplusplus
@@ -47,3 +19,25 @@ Index: unfs3-0.9.17/Config/lex.yy.c
  #endif
  #endif
  
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -12,7 +12,7 @@
+        md5.o mount.o nfs.o password.o readdir.o user.o xdr.o winsupport.o
+ CONFOBJ = Config/lib.a
+ EXTRAOBJ = @EXTRAOBJ@
+-LDFLAGS = @LDFLAGS@ @LIBS@ @LEXLIB@
++LDFLAGS = @LDFLAGS@ @LIBS@
+ EXEEXT = @EXEEXT@
+ prefix = @prefix@
+--- a/configure
++++ b/configure
+@@ -2604,7 +2604,7 @@
+     ac_save_LIBS=$LIBS
+     ac_cv_lib_lex='none needed'
+-    for ac_lib in '' -lfl -ll; do
++    for ac_lib in '' -ll; do
+       LIBS="$ac_lib $ac_save_LIBS"
+       cat >conftest.$ac_ext <<_ACEOF
+ `cat $LEX_OUTPUT_ROOT.c`