dhcpcd: moved to github
[packages.git] / net / ucarp / Makefile
index b02000f..67afdfc 100644 (file)
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucarp
-PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=1.5.2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
-PKG_MD5SUM:=9219ea8214198e8af751353a132087bb
+PKG_MD5SUM:=723636dbf79fc6abd329a71ec4ddf79d
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -21,6 +23,7 @@ define Package/ucarp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Lets several hosts share one IP
+  DEPENDS:=+ip +libpcap
   URL:=http://www.ucarp.org/project/ucarp
 endef
 
@@ -30,9 +33,17 @@ define Package/ucarp/description
  secure and patent-free Common Address Redundancy Protocol
 endef
 
+define Package/ucarp/conffiles
+/etc/ucarp.conf
+endef
+
 define Package/ucarp/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ucarp $(1)/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/ucarp.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/ucarp.init $(1)/etc/init.d/ucarp
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ucarp $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ucarp))