[packages] tor-alpha: update to 0.2.3.17-beta, disable bufferevents because of hangs...
[packages.git] / net / tor-alpha / Makefile
index 607b202..aa0a250 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-alpha
-PKG_VERSION:=0.2.3.5-alpha
-PKG_RELEASE:=3
+PKG_VERSION:=0.2.3.17-beta
+PKG_RELEASE:=1
 
 PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
        https://archive.torproject.org/tor-package-archive
-PKG_MD5SUM:=adae506a9599c2829fd3c25d1b3b77de
+PKG_MD5SUM:=d07158942df1c9e869a25a8a53446862
 
-PKG_BUILD_DEPENDS:=libnatpmp
+PKG_BUILD_DEPENDS:=libminiupnpc libnatpmp
 PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
 PKG_INSTALL:=1
 
@@ -50,7 +50,7 @@ endef
 define Package/tor-alpha-fw-helper
 $(call Package/tor-alpha/Default)
   TITLE:=Firewall helper for tor
-  DEPENDS:=+tor-alpha +libnatpmp
+  DEPENDS:=+tor-alpha +libminiupnpc +libnatpmp
 endef
 
 define Package/tor-alpha-fw-helper/description
@@ -76,11 +76,17 @@ endef
 CONFIGURE_ARGS += \
        --with-libevent-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
+       --enable-upnp \
+       --with-libminiupnpc-dir="$(STAGING_DIR)/usr" \
        --enable-nat-pmp \
        --with-libnatpmp-dir="$(STAGING_DIR)/usr" \
-       --enable-bufferevents \
        --disable-asciidoc
 
+ifneq ($(CONFIG_SSP_SUPPORT),y)
+       CONFIGURE_ARGS += \
+               --disable-gcc-hardening
+endif
+
 CONFIGURE_VARS += \
        CROSS_COMPILE="yes"