[packages] netatalk: update to 2.1.5
[packages.git] / net / tor-alpha / Makefile
index 301f839..254205f 100644 (file)
@@ -8,28 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-alpha
-PKG_VERSION:=0.2.2.22-alpha
+PKG_VERSION:=0.2.2.24-alpha
 PKG_RELEASE:=1
 
 PKG_SOURCE:=tor-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.torproject.org/dist \
-       http://archive.torproject.org/tor-package-archive
-PKG_MD5SUM:=482617714694340054b6669955e4271e
-PKG_BUILD_DIR=$(BUILD_DIR)/tor-$(PKG_VERSION)/
+       https://archive.torproject.org/tor-package-archive
+PKG_MD5SUM:=4c1e2c7d778f813d09227433fffe3990
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/tor-$(PKG_VERSION)
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/tor-alpha
+define Package/tor-alpha/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread +miniupnpc
-  TITLE:=An anonymous Internet communication system
-  URL:=http://www.torproject.org/
+  URL:=https://www.torproject.org/
 endef
 
-define Package/tor-alpha/description
+define Package/tor-alpha/Default/description
  Tor is a toolset for a wide range of organizations and people that want to
  improve their safety and security on the Internet. Using Tor can help you
  anonymize web browsing and publishing, instant messaging, IRC, SSH, and
@@ -37,6 +35,28 @@ define Package/tor-alpha/description
  new applications with built-in anonymity, safety, and privacy features.
 endef
 
+define Package/tor-alpha
+$(call Package/tor-alpha/Default)
+  TITLE:=An anonymous Internet communication system
+  DEPENDS:=+libevent +libopenssl +libpthread +librt +miniupnpc
+endef
+
+define Package/tor-alpha/description
+$(call Package/tor-alpha/Default/description)
+ This package contains the tor daemon.
+endef
+
+define Package/tor-alpha-geoip
+$(call Package/tor-alpha/Default)
+  TITLE:=GeoIP db for tor
+  DEPENDS:=+tor-alpha
+endef
+
+define Package/tor-alpha-geoip/description
+$(call Package/tor-alpha/Default/description)
+ This package contains a GeoIP database mapping IP addresses to countries.
+endef
+
 define Package/tor-alpha/conffiles
 /etc/tor/torrc
 endef
@@ -98,4 +118,10 @@ define Package/tor-alpha/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
+define Package/tor-alpha-geoip/install
+       $(INSTALL_DIR) $(1)/usr/share/tor
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor/
+endef
+
 $(eval $(call BuildPackage,tor-alpha))
+$(eval $(call BuildPackage,tor-alpha-geoip))