[packages] Use default templates instead of custom reimplementations where applicable
[packages.git] / net / tinc / Makefile
index 6457c84..290a8a1 100644 (file)
@@ -17,8 +17,12 @@ PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
 PKG_MD5SUM:=ee0b1a3366c6e379cae34be6fa5dcb15
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS+=-std=gnu99
+
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
@@ -41,12 +45,6 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/