packages/portsentry: pass optimization flags, disable daemon support, use new service...
[packages.git] / net / stunnel / Makefile
index 93161e9..98dd5d0 100644 (file)
@@ -1,12 +1,22 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=4.25
+PKG_VERSION:=4.33
 PKG_RELEASE:=1
-PKG_MD5SUM:=7f00799f43910c0362df0e69c65965aa
+
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=559a864066d8cc4afd8a97682c90d41c
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,33 +33,31 @@ define Package/stunnel/description
        connections inside SSL (Secure Sockets Layer) available on both Unix
        and Windows. Stunnel can allow you to secure non-SSL aware daemons and
        protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
-       encryption, requiring no changes to the daemon's code. 
+       encryption, requiring no changes to the daemon's code.
 endef
 
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-random=/dev/urandom \
-               --with-threads=fork \
-               --with-ssl=$(STAGING_DIR)/usr \
-       )
+define Package/stunnel/conffiles
+/etc/stunnel/stunnel.conf
 endef
 
-define Build/Compile   
+CONFIGURE_ARGS+= \
+       --with-random=/dev/urandom \
+       --with-threads=fork \
+       --with-ssl=$(STAGING_DIR)/usr \
+
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
        echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Compile/Default)
 endef
 
-define Package/stunnel/install 
+define Package/stunnel/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/stunnel
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
        $(INSTALL_DIR) $(1)/etc/stunnel
-       $(INSTALL_CONF) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.conf-sample $(1)/etc/stunnel/stunnel.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/stunnel
 endef