[packages] stunnel: cleanup
[packages.git] / net / stunnel / Makefile
index 36c7391..98dd5d0 100644 (file)
@@ -1,16 +1,22 @@
-# $Id$
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=4.20
+PKG_VERSION:=4.33
 PKG_RELEASE:=1
-PKG_MD5SUM:=cf9940395d3503018f721c962528d2ec
+
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=559a864066d8cc4afd8a97682c90d41c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -19,37 +25,41 @@ define Package/stunnel
   CATEGORY:=Network
   DEPENDS:=+libopenssl +libwrap
   TITLE:=SSL TCP Wrapper
-  URL:=http://stunnel.org
+  URL:=http://www.stunnel.org/
 endef
 
 define Package/stunnel/description
-        Open source SSL TCP Wrapper
+       Stunnel is a program that allows you to encrypt arbitrary TCP
+       connections inside SSL (Secure Sockets Layer) available on both Unix
+       and Windows. Stunnel can allow you to secure non-SSL aware daemons and
+       protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
+       encryption, requiring no changes to the daemon's code.
 endef
 
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-random=/dev/urandom \
-               --with-threads=fork \
-               --with-ssl=$(STAGING_DIR)/usr \
-       )
+define Package/stunnel/conffiles
+/etc/stunnel/stunnel.conf
 endef
 
-define Build/Compile   
+CONFIGURE_ARGS+= \
+       --with-random=/dev/urandom \
+       --with-threads=fork \
+       --with-ssl=$(STAGING_DIR)/usr \
+
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
        echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Compile/Default)
 endef
 
-define Package/stunnel/install 
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/usr/lib $(1)/usr/stunnel
-       $(INSTALL_DIR) $(1)/etc/stunnel $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/stunnel $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstunnel.so $(1)/usr/sbin/
-       $(CP) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
-       $(CP) ./files/stunnel.init $(1)/etc/init.d/S90stunnel
+define Package/stunnel/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib/stunnel
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
+       $(INSTALL_DIR) $(1)/etc/stunnel
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.conf-sample $(1)/etc/stunnel/stunnel.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/stunnel.init $(1)/etc/init.d/stunnel
 endef
 
 $(eval $(call BuildPackage,stunnel))