packages/zaptel-1.4: fix Kconfig options
[packages.git] / net / ssltunnel / Makefile
index 6146cd0..84ddadb 100644 (file)
@@ -4,20 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssltunnel
-PKG_VERSION:=1.15
+PKG_VERSION:=1.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=${PKG_NAME}-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hsc.fr/ressources/outils/ssltunnel/download
-PKG_MD5SUM:=bfe529edb9b6c97bc03d213676b1f35d
+PKG_MD5SUM:=4039b50566a33a4077883ea974e476d5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,11 +23,20 @@ define Package/ssltunnel
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+ppp +libopenssl
-  TITLE:=A PPP over SSL vpn tool
+  TITLE:=A PPP over SSL VPN tool
   URL:=http://www.hsc.fr/ressources/outils/ssltunnel/index.html
   SUBMENU:=VPN
 endef
 
+define Package/ssltunnel/description
+       SSLTunnel is a client/server program to create a PPP connection over a
+       SSL/TLS session.
+       Client and server are mutually authenticated using a X509 certificate,
+       PPP packets are then encrypted/decrypted realtime on each side.
+       It's possible to use ssltunnel to connect a machine to another, a
+       machine with a network or two networks sets.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                , \
@@ -38,12 +45,6 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/ssltunnel/install       
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pppclient $(1)/usr/bin/