packages/memcached: update to 1.4.7 (closes: #10046)
[packages.git] / net / squid / Makefile
index ba9ed67..f96b696 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,32 +8,33 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.6.STABLE23
-PKG_RELEASE:=1
+PKG_VERSION:=2.7.STABLE9
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
-PKG_MD5SUM:=71aa24580f8a538ad84037bf2ac6f078
+PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.7/
+PKG_MD5SUM:=3c6642c85470b1079207d43bba25a819
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   URL:=http://www.squid-cache.org/
 endef
 
 define Package/squid
   $(call Package/squid/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpthread @LINUX_2_6
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=full-featured Web proxy cache
 endef
 
 define Package/squid/description
-       Squid is a high-performance proxy caching server for web clients, 
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
-       caching software, Squid handles all requests in a single, 
+       Squid is a high-performance proxy caching server for web clients,
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional
+       caching software, Squid handles all requests in a single,
        non-blocking, I/O-driven process.
 endef
 
@@ -126,6 +127,7 @@ CONFIGURE_ARGS += \
        --enable-ntlm-auth-helpers="fakeauth SMB" \
        --enable-digest-auth-helpers="password" \
        --enable-external-acl-helpers="ip_user unix_group" \
+       --enable-storeio=null,ufs \
        --enable-epoll \
        --with-maxfd=4096
 
@@ -136,7 +138,6 @@ CONFIGURE_VARS += \
 define Build/Compile
        # pass INCLUDES to compile host sources against our OpenSSL, not the host one
        $(MAKE) -C $(PKG_BUILD_DIR)/lib \
-               INCLUDES="$(TARGET_CPPFLAGS)" \
                all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -161,7 +162,7 @@ define Package/squid/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger,logfile-daemon} $(1)/usr/lib/squid/
 endef
 
 define Package/squid-mod-cachemgr/install