[packages] asterisk-1.8.x: upgrade to 1.8.7.1
[packages.git] / net / samba / Makefile
index 613d546..28c2bd7 100644 (file)
@@ -1,54 +1,65 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=2.0.10
-PKG_RELEASE:=2
+PKG_RELEASE:=6
 PKG_MD5SUM:=54870482fe036b7e69dd48c90661eec6
 
-PKG_SOURCE_URL:=ftp://se.samba.org/pub/samba/stable \
-       ftp://ftp.easynet.be/samba/stable
+PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/samba
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=A NetBIOS/SMB implementation
-  TITLE:=A NetBIOS/SMB implementation
-  DESCRIPTION:=The Samba software suite is a collection of programs that implements the\\\
-  SMB protocol for unix systems, allowing you to serve files and printers to\\\
-  Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred\\\
-  to as the LanManager or Netbios protocol.
+  SUBMENU:=Filesystem
+  TITLE:=samba - NetBIOS/SMB implementation
   URL:=http://www.samba.org/
 endef  
 
-define Package/samba-server
+define Package/samba/description
+The Samba software suite is a collection of programs that implements the
+       SMB protocol for unix systems, allowing you to serve files and printers to
+       Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred
+       to as the LanManager or Netbios protocol.
+endef
+
+define Package/samba2-common
+  $(call Package/samba)
+  MENU:=1
+  TITLE:=NetBIOS/SMB server and client shared files
+  DEPENDS:=+libgcc
+endef
+
+define Package/samba2-server
   $(call Package/samba)
   TITLE:=NetBIOS/SMB file and print server
+  DEPENDS:=samba2-common
 endef
 
-define Package/samba-client
+define Package/samba2-client
   $(call Package/samba)
   TITLE:=NetBIOS/SMB simple client
+  DEPENDS:=samba2-common
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        (cd $(PKG_BUILD_DIR)/source ; rm -rf config.{cache,status} ; \
                ./configure \
+                       $(HOST_CONFIGURE_VARS) \
+                       $(HOST_CONFIGURE_ARGS) \
                        --program-prefix="" \
                        --program-suffix="" \
                        --prefix=/usr \
@@ -63,7 +74,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -79,12 +89,9 @@ define Build/Compile
        (cd $(PKG_BUILD_DIR)/source; rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE -DNDEBUG -DSHMEM_SIZE=524288 -Dfcntl=fcntl64" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-lgcc_s -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) $(LIBGCC_S)" \
                ac_cv_lib_cups_httpConnect=no \
-               ac_cv_sizeof_int=4 \
-               ac_cv_sizeof_long=4 \
-               ac_cv_sizeof_short=2 \
                samba_cv_FTRUNCATE_NEEDS_ROOT=no \
                samba_cv_HAVE_BROKEN_FCNTL64_LOCKS=no \
                samba_cv_HAVE_BROKEN_GETGROUPS=no \
@@ -137,7 +144,6 @@ define Build/Compile
                        --mandir=/usr/share/man \
                        --sbindir=/usr/sbin \
                        --sysconfdir=/etc/samba \
-                       $(DISABLE_LARGEFILE) \
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
@@ -169,27 +175,35 @@ define Build/Compile
                install
 endef
 
-define Package/samba-server/install    
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/samba.init $(1)/etc/init.d/samba
-       install -d -m0755 $(1)/etc/samba
-       install -m0644 ./files/smb.conf $(1)/etc/samba/smb.conf
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/source/bin/smbpasswd.shared $(1)/usr/bin/smbpasswd
-       install -d -m0755 $(1)/usr/lib
-       install -m0755 $(PKG_BUILD_DIR)/source/bin/libsmb.so $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/source/bin/nmbd.shared $(1)/usr/sbin/nmbd
-       install -m0755 $(PKG_BUILD_DIR)/source/bin/smbd.shared $(1)/usr/sbin/smbd
-       install -d -m0755 $(1)/usr/share/samba
-       install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{437,850} $(1)/usr/share/samba/
-       install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850} $(1)/usr/share/samba/
+define Package/samba2-common/install
+       $(INSTALL_DIR) $(1)/etc/samba
+       $(INSTALL_DATA) ./files/smb.conf $(1)/etc/samba/smb.conf
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbpasswd.shared $(1)/usr/bin/smbpasswd
+       $(INSTALL_DIR) $(1)/usr/share/samba
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{437,850} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850,ISO8859-1,ISO8859-15} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.852 $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{852,ISO8859-2} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{866,1251} $(1)/usr/share/samba/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{866,ISO8859-5,KOI8-R,1251} $(1)/usr/share/samba/
+endef
+
+define Package/samba2-server/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/libsmb.so $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/nmbd.shared $(1)/usr/sbin/nmbd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbd.shared $(1)/usr/sbin/smbd
 endef
 
-define Package/samba-client/install    
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/bin/smbclient $(1)/usr/bin/
+define Package/samba2-client/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/smbclient $(1)/usr/bin/
 endef
 
-$(eval $(call BuildPackage,samba-server))
-$(eval $(call BuildPackage,samba-client))
+$(eval $(call BuildPackage,samba2-common))
+$(eval $(call BuildPackage,samba2-server))
+$(eval $(call BuildPackage,samba2-client))