packages/rsync: update to 3.0.9
[packages.git] / net / rsync / Makefile
index 5041eb6..650b661 100644 (file)
@@ -1,31 +1,42 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-#
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
-PKG_VERSION:=3.0.6
+PKG_VERSION:=3.0.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
-PKG_MD5SUM:=e9865d093a18e4668b9d31b635dc8e99
+PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/src
+PKG_MD5SUM:=5ee72266fe2c1822333c407e1761b92b
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/rsync
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
   DEPENDS:=+libpopt
   URL:=http://rsync.samba.org/
 endef
 
+define Package/rsyncd
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=File Transfer
+  TITLE:=Rsync daemon
+  DEPENDS:=+rsync
+endef
+
 define Package/rsync/description
        rsync is a program that allows files to be copied to
        and from remote machines in much the same way as rcp.
@@ -47,7 +58,25 @@ CONFIGURE_ARGS += \
 
 define Package/rsync/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+endef
+
+define Package/rsyncd/description
+       rsyncd is a configuration file and initscript to
+       utilize rsync as a daemon. It uses the same binary
+       as rsync.
+endef
+
+define Package/rsyncd/conffiles
+/etc/rsyncd.conf
+endef
+
+define Package/rsyncd/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/rsyncd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/rsyncd.init $(1)/etc/init.d/rsyncd
 endef
 
 $(eval $(call BuildPackage,rsync))
+$(eval $(call BuildPackage,rsyncd))