[package] babeld: Fix reload rule in init script
[packages.git] / net / radsecproxy / Makefile
index f6e4e89..df7a878 100644 (file)
@@ -1,29 +1,28 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radsecproxy
-PKG_VERSION:=1.0p1
+PKG_VERSION:=1.3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
-PKG_MD5SUM:=d1bdfd731342eda1242ba94703165fbe
+PKG_MD5SUM:=565b389268d906c3b465f63750938667
 
-PKG_BUILD_DEPENDS:= libopenssl libpthread zlib
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/radsecproxy
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +libpthread +zlib
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=radsecproxy
   URL:=http://software.uninett.no/radsecproxy
 endef
@@ -35,17 +34,9 @@ endef
 CONFIGURE_ARGS+= \
        --with-ssl="$(STAGING_DIR)/usr"
 
-#LIBS="-lz" \
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/radsecproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/
        $(CP) $(PKG_INSTALL_DIR)/etc/radsecproxy.conf-example $(1)/etc/radsecproxy.conf
        $(INSTALL_DIR) $(1)/etc/init.d/