[package] gpsd: use autogen.sh
[packages.git] / net / proftpd / Makefile
index 33334e1..3a076a8 100644 (file)
@@ -1,30 +1,36 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=proftpd
-PKG_VERSION:=1.3.2a
+PKG_VERSION:=1.3.3d
 PKG_RELEASE:=1
-PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
-PKG_MD5SUM:=ad3cbb5db30c5ae39e09b308892392b3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL=1
+PKG_SOURCE_URL:=ftp://ftp.proftpd.org/distrib/source
+PKG_MD5SUM:=69650e91e05b3a10fa3ac54ee261679b
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/proftpd
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
   TITLE:=ProFTPD FTP server
   URL:=http://www.proftpd.org/
+  MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl> 
+endef
+
+define Package/proftpd/conffiles
+/etc/proftpd.conf
 endef
 
 TARGET_CPPFLAGS += \
@@ -35,16 +41,20 @@ MAKE_FLAGS += \
        INSTALL_GROUP=$(shell id -g)
 
 CONFIGURE_ARGS += \
-       --disable-cap
+       --disable-cap \
+       --enable-devel \
 
 define Package/proftpd/install
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-       rm -rf \
-               $(1)/usr/include \
-               $(1)/usr/share \
-               $(1)/usr/man \
-               $(1)/usr/lib/pkgconfig \
-               $(1)/var
+       $(INSTALL_DIR) $(1)/etc
+       $(if $(CONFIG_IPV6),,$(SED) 's/^UseIPv6/#UseIPv6/' $(PKG_INSTALL_DIR)/etc/proftpd.conf)
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/proftpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/proftpd.init $(1)/etc/init.d/proftpd
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ftp{count,top,who} $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{ftpshut,proftpd} $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/in.proftpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,proftpd))