[packages] Use default templates instead of custom reimplementations where applicable
[packages.git] / net / opendchub / Makefile
index cc4a3f3..db4e7c6 100644 (file)
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/opendchub
 PKG_MD5SUM:=8f9ab5bb7f85730f4b1ce7cceb6aef96
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/opendchub
@@ -37,14 +39,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
-endef
-
-define Package/opendchub/install       
+define Package/opendchub/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opendchub $(1)/usr/bin/
 endef