packages/apr-utils: force use of LFS and 64-bit off_t
[packages.git] / net / oidentd / Makefile
index 5aa4ae8..ef60431 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,9 +14,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ojnk
 PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,11 +21,13 @@ define Package/oidentd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Identd server 
-  DESCRIPTION:=\
-       A nat aware identd server that will correctly forwared requests to clients.
   URL:=http://dev.ojnk.net/
 endef
 
+define Package/oidentd/description
+       A nat aware identd server that will correctly forwared requests to clients.
+endef
+
 # uses GNU configure
 
 define Build/Compile
@@ -38,9 +36,9 @@ endef
 
 define Package/oidentd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/src/oidentd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
+       $(INSTALL_BIN) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef
 
 $(eval $(call BuildPackage,oidentd))