xl2tpd: fix passing our CFLAGS
[packages.git] / net / nprobe / Makefile
index 8235c22..400bc9b 100644 (file)
@@ -1,22 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nprobe
 PKG_VERSION:=4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=nProbe-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
 PKG_MD5SUM:=32ed12f60eab771a79bd5f90622fa2a3
 
 BUILD_DEPENDS:=libwrap
+PKG_FIXUP:=autoreconf
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/nProbe
 
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nprobe
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libpcap +libpcre +libpthread +NPROBE_MYSQL_SUPPORT:libmysqlclient
+  DEPENDS:=+libpcap +libpcre +libpthread +NPROBE_MYSQL_SUPPORT:libmysqlclient +zlib
   TITLE:=nProbe
   URL:=http://invisible-island.net/dialog/
 endef