pyload: update to current version 0.4.9
[packages.git] / net / nocatsplash / Makefile
index baed640..c63fdca 100644 (file)
@@ -8,15 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nocatsplash
-PKG_VERSION:=0.92
+PKG_VERSION:=0.93pre2
 PKG_RELEASE:=2
 
 PKG_SOURCE:=NoCatSplash-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://wifi.rulez.org/~josephus/
-PKG_MD5SUM:=e0fcc0effe52e63bc31070d16d0b4a81
+PKG_SOURCE_URL:=http://nocat.net/downloads/NoCatSplash/
+PKG_MD5SUM:=b0aa5cc33a3bbdd8e65726ff3cfe3cd1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/NoCatSplash-$(PKG_VERSION)
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nocatsplash
@@ -30,10 +32,10 @@ endef
 
 define Package/nocatsplash/description
        NoCatSplash is an Open Public Network Gateway Daemon.
-       It performs as a [captive/open/active] portal. When run on a gateway/router 
-       on a network, all web requests are redirected until the client either logs 
-       in or clicks "I Accept" to an AUP. The gateway daemon then changes the 
-       firewall rules on the gateway to pass traffic for that client (based on IP 
+       It performs as a [captive/open/active] portal. When run on a gateway/router
+       on a network, all web requests are redirected until the client either logs
+       in or clicks "I Accept" to an AUP. The gateway daemon then changes the
+       firewall rules on the gateway to pass traffic for that client (based on IP
        address and MAC address).
 endef
 
@@ -48,16 +50,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/nocatsplash/install     
+define Package/nocatsplash/install
        $(INSTALL_DIR) $(1)
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,nocatsplash))