Port nocatsplash to -ng
[packages.git] / net / nocatsplash / Makefile
diff --git a/net/nocatsplash/Makefile b/net/nocatsplash/Makefile
new file mode 100644 (file)
index 0000000..9892e0e
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nocatsplash
+PKG_VERSION:=0.92
+PKG_RELEASE:=1
+PKG_MD5SUM:=e0fcc0effe52e63bc31070d16d0b4a81
+
+PKG_SOURCE_URL:=http://wifi.rulez.org/~josephus/
+PKG_SOURCE:=NoCatSplash-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/NoCatSplash-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nocatsplash
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+glib
+  TITLE:=Open public network gateway daemon
+  DESCRIPTION:=NoCatSplash is an Open Public Network Gateway Daemon.\\\
+       It performs as a [captive/open/active] portal. When run on a gateway/router\\\
+       on a network, all web requests are redirected until the client either logs\\\
+       in or clicks "I Accept" to an AUP. The gateway daemon then changes the\\\
+       firewall rules on the gateway to pass traffic for that client (based on IP\\\
+       address and MAC address).\\\
+  URL:=http://nocat.net
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,        --with-firewall=iptables \
+                 --with-glib-prefix="$(STAGING_DIR)/usr")
+endef
+
+define Build/Compile   
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/nocatsplash/install     
+       mkdir -p $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/ 
+endef
+
+$(eval $(call BuildPackage,nocatsplash))