tar: moved to github
[packages.git] / net / netpipe / Makefile
index 13d1309..bb1bc08 100644 (file)
@@ -1,37 +1,49 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netpipe
-PKG_VERSION:=3.6.2
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=NetPIPE_$(PKG_VERSION).tar.gz
+PKG_SOURCE:=NetPIPE-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.scl.ameslab.gov/netpipe/code
-PKG_MD5SUM:=62570140a3617eca4b15b3255d3edbe6
-PKG_CAT:=zcat
+PKG_MD5SUM:=cc458a9154f6b8c6da9fae16627beec4
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/NetPIPE_$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/NetPIPE-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/netpipe
   SECTION:=net
-  CATEGORY:=Networking
+  CATEGORY:=Network
   TITLE:=A Network Protocol Independent Performance Evaluator
-  DESCRIPTION:=A Network Protocol Independent Performance Evaluator
   URL:=http://www.scl.ameslab.gov/netpipe/
 endef
 
+define Package/netpipe/description
+       NetPIPE is a protocol independent performance tool that visually
+       represents the network performance under a variety of conditions. It
+       performs simple ping-pong tests, bouncing messages of increasing size
+       between two processes, whether across a network or within an SMP
+       system. Message sizes are chosen at regular intervals, and with slight
+       perturbations, to provide a complete test of the communication system.
+       Each data point involves many ping-pong tests to provide an accurate
+       timing. Latencies are calculated by dividing the round trip time in
+       half for small messages ( < 64 Bytes ).
+endef
+
 define Build/Configure
 endef
 
+MAKE_FLAGS += \
+       $(TARGET_CONFIGURE_OPTS)
+
 define Package/netpipe/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPtcp $(1)/usr/bin/