packages/memcached: update to 1.4.7 (closes: #10046)
[packages.git] / net / net-snmp / Makefile
index 3cb36df..05de29b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.4.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
 PKG_MD5SUM:=984932520143f0c8bf7b7ce1fc9e1da1
 
-PKG_FIXUP = libtool
+PKG_FIXUP = libtool no-autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,10 +26,10 @@ define Package/net-snmp/Default
 endef
 
 define Package/net-snmp/Default/description
- Simple Network Management Protocol (SNMP) is a widely used protocol for 
- monitoring the health and welfare of network equipment (eg. routers), 
- computer equipment and even devices like UPSs. Net-SNMP is a suite of 
- applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both 
+ Simple Network Management Protocol (SNMP) is a widely used protocol for
+ monitoring the health and welfare of network equipment (eg. routers),
+ computer equipment and even devices like UPSs. Net-SNMP is a suite of
+ applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both
  IPv4 and IPv6.
 endef
 
@@ -98,6 +98,7 @@ SNMP_MIB_MODULES_INCLUDED = \
        host/hr_storage \
        host/hr_system \
        ieee802dot11 \
+       if-mib/ifXTable \
        mibII/at \
        mibII/icmp \
        mibII/ifTable \
@@ -111,6 +112,7 @@ SNMP_MIB_MODULES_INCLUDED = \
        mibII/vacm_vars \
        snmpv3/snmpEngine \
        snmpv3/snmpMPDStats \
+       snmpv3/usmConf \
        snmpv3/usmStats \
        snmpv3/usmUser \
        tunnel \
@@ -143,13 +145,14 @@ SNMP_MIB_MODULES_EXCLUDED = \
        udp-mib \
        utilities \
 
-SNMP_TRANSPORTS_INCLUDED = Callback UDP 
+SNMP_TRANSPORTS_INCLUDED = Callback UDP
 
 SNMP_TRANSPORTS_EXCLUDED = TCP TCPIPv6 Unix
 
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
+       --enable-mfd-rewrites \
        --enable-shared \
        --enable-static \
        --with-endianness=little \
@@ -171,10 +174,10 @@ CONFIGURE_ARGS += \
        --without-libwrap \
        --without-rpm \
        --without-zlib \
+        $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 ifeq ($(CONFIG_IPV6),y)
 SNMP_TRANSPORTS_INCLUDED+= UDPIPv6
-CONFIGURE_ARGS+= --enable-ipv6
 endif
 
 TARGET_LDFLAGS += -L$(TOOLCHAIN_DIR)/usr/lib
@@ -192,7 +195,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                LDFLAGS="$(TARGET_LDFLAGS) -lm -lc" \
-               all install     
+               all install
        $(Build/Compile/static)
 endef