[packages] quagga-unstable: Update to v0.99.14 and refresh patches
[packages.git] / net / kismet / Makefile
index eb490e6..9e6675d 100644 (file)
@@ -4,19 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
-PKG_VERSION:=2007-01-R1a
-PKG_RELEASE:=1
+PKG_VERSION:=2008-05-R1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
-PKG_MD5SUM:=5921166366d3f695eeef26121c56a674
+PKG_MD5SUM:=6ee365d36354b4dee4945e67f8149294
 
-PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
+PKG_BUILD_DEPENDS:=libpcap libncurses uclibcxx
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,10 +25,11 @@ define Package/kismet/Default
   TITLE:=Kismet
   DEPENDS:= +uclibcxx
   URL:=http://www.kismetwireless.net/
+  SUBMENU:=wireless
 endef
 
 define Package/kismet/Default/description
- An 802.11 layer2 wireless network detector, sniffer, and intrusion 
+ An 802.11 layer2 wireless network detector, sniffer, and intrusion
  detection system.
 endef
 
@@ -53,7 +53,7 @@ endef
 
 define Package/kismet-drone
 $(call Package/kismet/Default)
-  DEPENDS+= +libpcap
+  DEPENDS+= +libpcap +dbus
   TITLE+= drone
 endef
 
@@ -68,7 +68,7 @@ endef
 
 define Package/kismet-server
 $(call Package/kismet/Default)
-  DEPENDS+= +libpcap
+  DEPENDS+= +libpcap +dbus
   TITLE+= server
 endef
 
@@ -84,7 +84,9 @@ $(call Package/kismet/Default/description)
 endef
 
 CONFIGURE_ARGS += \
+       --sysconfdir=/etc/kismet \
        --enable-syspcap=yes \
+       --disable-dbus \
        --disable-setuid \
        --disable-wsp100 \
        --disable-gpsmap \
@@ -93,7 +95,7 @@ CONFIGURE_VARS += \
        CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
        LDFLAGS="$$$$LDFLAGS" \
-       LIBS="-nodefaultlibs -luClibc++ -lm -lnotimpl" \
+       LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \