[package] configure kismet to search for its configuration file in /etc/kismet instea...
[packages.git] / net / kismet / Makefile
index 756f02d..9b66d53 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
-PKG_VERSION:=2007-01-R1a
-PKG_RELEASE:=1
+PKG_VERSION:=2008-05-R1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
-PKG_MD5SUM:=5921166366d3f695eeef26121c56a674
+PKG_MD5SUM:=6ee365d36354b4dee4945e67f8149294
 
 PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
 
@@ -30,7 +30,7 @@ define Package/kismet/Default
 endef
 
 define Package/kismet/Default/description
- An 802.11 layer2 wireless network detector, sniffer, and intrusion 
+ An 802.11 layer2 wireless network detector, sniffer, and intrusion
  detection system.
 endef
 
@@ -54,7 +54,7 @@ endef
 
 define Package/kismet-drone
 $(call Package/kismet/Default)
-  DEPENDS+= +libpcap
+  DEPENDS+= +libpcap +dbus
   TITLE+= drone
 endef
 
@@ -69,7 +69,7 @@ endef
 
 define Package/kismet-server
 $(call Package/kismet/Default)
-  DEPENDS+= +libpcap
+  DEPENDS+= +libpcap +dbus
   TITLE+= server
 endef
 
@@ -85,7 +85,9 @@ $(call Package/kismet/Default/description)
 endef
 
 CONFIGURE_ARGS += \
+       --sysconfdir=/etc/kismet \
        --enable-syspcap=yes \
+       --disable-dbus \
        --disable-setuid \
        --disable-wsp100 \
        --disable-gpsmap \
@@ -94,7 +96,7 @@ CONFIGURE_VARS += \
        CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
        LDFLAGS="$$$$LDFLAGS" \
-       LIBS="-nodefaultlibs -luClibc++ -lm -lnotimpl" \
+       LIBS="-nodefaultlibs -luClibc++ -lm -lnotimpl -lgcc" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \