[packages] hiawatha: update to 7.7 (thanks to Raphael Huck)
[packages.git] / net / hiawatha / Makefile
index adc48f3..6b99e9e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
-PKG_VERSION:=7.3
+PKG_VERSION:=7.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
-PKG_MD5SUM:=52fd6bf798c07298e12ff69b882f3d76
+PKG_MD5SUM:=7195c829c86f1ed37d314daa4e06d06b
+
+PKG_CONFIG_DEPENDS:= \
+       CONFIG_IPV6 \
 
 PKG_INSTALL:=1
 
@@ -30,10 +33,11 @@ define Package/hiawatha
 endef
 
 define Package/hiawatha/description
-Hiawatha is an open source webserver with a focus on security.
+  Hiawatha is an open source webserver with a focus on security.
 endef
 
 CONFIGURE_ARGS+= \
+       $(call autoconf_bool,CONFIG_IPV6,ipv6) \
        --disable-cache \
        --disable-monitor \
        --disable-ssl \